<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-GB"> <!--<![endif]-->
<head>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.ghpage.com/xmlrpc.php" />
    <meta property="og:image" content="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley.jpg" /><meta name="author" content="Mr. Tabernacle">
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/01/fav-e1546446718696.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/01/fav-e1546446718696.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/01/fav-e1546446718696.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/01/fav-e1546446718696.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/01/fav-e1546446718696.png"/>
	<!-- This site is optimized with the Yoast SEO Premium plugin v15.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Please forgive me- Lady who called Sally Galley horror and barren apologizes - GhPage</title>
	<meta name="description" content="Henewaa Piesie, the lady who called actress Selly Galley horror and barren has taken back her words and finally apologized. The" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/" />
	<meta property="og:locale" content="en_GB" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Please forgive me; you will give birth by next year- Lady who called Sally Galley horror and barren apologizes" />
	<meta property="og:description" content="Henewaa Piesie, the lady who called actress Selly Galley horror and barren has taken back her words and finally apologized. The" />
	<meta property="og:url" content="https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/" />
	<meta property="og:site_name" content="GhPage" />
	<meta property="article:publisher" content="https://www.facebook.com/ghpagenews/" />
	<meta property="article:author" content="https://www.facebook.com/ghpagenews/" />
	<meta property="article:published_time" content="2020-10-14T19:29:11+00:00" />
	<meta property="article:modified_time" content="2020-10-14T19:29:13+00:00" />
	<meta property="og:image" content="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<meta property="fb:app_id" content="1933869666887959" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@ghpage_com" />
	<meta name="twitter:site" content="@ghpage_com" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.ghpage.com/#organization","name":"GhPage","url":"https://www.ghpage.com/","sameAs":["https://www.facebook.com/ghpagenews/","https://www.instagram.com/ghpagenews/","https://www.youtube.com/channel/UCov4vYMln30lLf2tukR6_YQ","https://www.pinterest.com/ghanapage/","https://twitter.com/ghpage_com"],"logo":{"@type":"ImageObject","@id":"https://www.ghpage.com/#logo","inLanguage":"en-GB","url":"https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/08/ghpage-o.png","width":183,"height":48,"caption":"GhPage"},"image":{"@id":"https://www.ghpage.com/#logo"}},{"@type":"WebSite","@id":"https://www.ghpage.com/#website","url":"https://www.ghpage.com/","name":"GhPage","description":"Latest Ghana News and Ghana Entertainment News","publisher":{"@id":"https://www.ghpage.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.ghpage.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/#primaryimage","inLanguage":"en-GB","url":"https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley.jpg","width":1280,"height":720,"caption":"Henewaa Piesie and Selly Galley"},{"@type":"WebPage","@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/#webpage","url":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/","name":"Please forgive me- Lady who called Sally Galley horror and barren apologizes - GhPage","isPartOf":{"@id":"https://www.ghpage.com/#website"},"primaryImageOfPage":{"@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/#primaryimage"},"datePublished":"2020-10-14T19:29:11+00:00","dateModified":"2020-10-14T19:29:13+00:00","description":"Henewaa Piesie, the lady who called actress Selly Galley horror and barren has taken back her words and finally apologized. The","breadcrumb":{"@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/#breadcrumb"},"inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/"]}]},{"@type":"BreadcrumbList","@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.ghpage.com/","url":"https://www.ghpage.com/","name":"GhPage"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.ghpage.com/category/entertainment/","url":"https://www.ghpage.com/category/entertainment/","name":"Entertainment"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/","url":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/","name":"Please forgive me- Lady who called Sally Galley horror and barren apologizes"}}]},{"@type":["Article","NewsArticle"],"@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/#article","isPartOf":{"@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/#webpage"},"author":{"@id":"https://www.ghpage.com/#/schema/person/93b6a5eb11f0e8c008e0c663790054f7"},"headline":"Please forgive me- Lady who called Sally Galley horror and barren apologizes","datePublished":"2020-10-14T19:29:11+00:00","dateModified":"2020-10-14T19:29:13+00:00","mainEntityOfPage":{"@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/#webpage"},"publisher":{"@id":"https://www.ghpage.com/#organization"},"image":{"@id":"https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/#primaryimage"},"keywords":"Selly Galley","articleSection":"Entertainment","inLanguage":"en-GB","copyrightYear":"2020","copyrightHolder":{"@id":"https://www.ghpage.com/#organization"}},{"@type":"Person","@id":"https://www.ghpage.com/#/schema/person/93b6a5eb11f0e8c008e0c663790054f7","name":"Mr. Tabernacle","image":{"@type":"ImageObject","@id":"https://www.ghpage.com/#personlogo","inLanguage":"en-GB","url":"https://secure.gravatar.com/avatar/37afaff810c8b636cdf6ce5b64f2583d?s=96&d=mm&r=g","caption":"Mr. Tabernacle"},"description":"Mr. Tabernacle is a proud staff at Ghpage, who is working hard to Cause a positive change in the online media phase. Loves to read, write, dance, act, groom, play football, and at leisure turns to a research wizard.","sameAs":["https://www.ghpage.com/","https://www.facebook.com/ghpagenews/"]}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.12.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.12.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-78917039-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-78917039-1', 'auto', {'useAmpClientId':true});
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('set', 'dimension1', 'Mr. Tabernacle');
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ghpage.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=edf919ddf144a00b28d2c557749d4880"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-includes/css/dist/block-library/style.min.css?ver=edf919ddf144a00b28d2c557749d4880' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=1a221c8450bc290d78da968c50c142a1' type='text/css' media='all' />
<link rel='stylesheet' id='td-multipurpose-css'  href='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/td-composer/assets/fonts/td-multipurpose/td-multipurpose.css?ver=1a221c8450bc290d78da968c50c142a1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/td-composer/mobile/style.css?ver=10.3.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.0.2' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.ghpage.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/google-analytics-premium/assets/js/frontend.min.js?ver=7.12.2' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<link rel="https://api.w.org/" href="https://www.ghpage.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.ghpage.com/wp-json/wp/v2/posts/161347" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ghpage.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://www.ghpage.com/?p=161347' />
<link rel="alternate" type="application/json+oembed" href="https://www.ghpage.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ghpage.com%2Fplease-forgive-me-lady-sally-galley-horror-barren-apologizes%2F161347%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ghpage.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ghpage.com%2Fplease-forgive-me-lady-sally-galley-horror-barren-apologizes%2F161347%2F&#038;format=xml" />
<meta property="fb:pages" content="1030530790352487" />		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
		<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.ghpage.com\/wp-admin\/","wpRestNonce":"4460d8059a","wpRestUrl":"https:\/\/www.ghpage.com\/wp-json\/","permalinkStructure":"\/%postname%\/%post_id%\/"};
			</script>
			      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.ghpage.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '5316bfdd-5af2-4993-a510-3ecabac218f9';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.054b4fc9-febb-45d1-b366-8fc183da0d9e";
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<link rel="amphtml" href="https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/?amp">
<!-- JS generated by theme -->

<script>
    
    
        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();


        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    

    
var td_ajax_url="https:\/\/www.ghpage.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=10.3.6.1";
var tdThemeName="Newspaper";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
</script>


<!-- Header style compiled by theme -->

<style>
    
.td-header-wrap {
	        background-color: #020056;
	    }
	    
	    .td-mobile-content .current-menu-item > a,
	    .td-mobile-content .current-menu-ancestor > a,
	    .td-mobile-content .current-category-ancestor > a,
	    #td-mobile-nav .td-menu-login-section a:hover,
	    #td-mobile-nav .td-register-section a:hover,
	    #td-mobile-nav .td-menu-socials-wrap a:hover i,
	    .td-search-close a:hover i {
	        color: #4db2ec;
	    }
	
	    
	    .td-menu-background:before,
	    .td-search-background:before {
	        background: #020056;
	        background: -moz-linear-gradient(top, #020056 0%, #020056 100%);
	        background: -webkit-gradient(left top, left bottom, color-stop(0%, #020056), color-stop(100%, #020056));
	        background: -webkit-linear-gradient(top, #020056 0%, #020056 100%);
	        background: -o-linear-gradient(top, #020056 0%, #020056 100%);
	        background: -ms-linear-gradient(top, #020056 0%, #020056 100%);
	        background: linear-gradient(to bottom, #020056 0%, #020056 100%);
	        filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#020056', endColorstr='#020056', GradientType=0 );
	    }
	
	
	     
	    .td-mobile-footer-wrap {
	        background-color: #020056;
	    }
	     
	    .td-mobile-sub-footer-wrap {
	        background-color: #020056;
	    }
	
	    
	    .td-post-content p,
	    .td-post-content {
	        font-size:18px;
	
	    }
</style>

<script data-ad-client="ca-pub-4775187669258590" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"0+S2o1QolK10vg", domain:"ghpage.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=0+S2o1QolK10vg" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->  <link rel="icon" href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/01/cropped-fav-6-32x32.png" sizes="32x32" />
<link rel="icon" href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/01/cropped-fav-6-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/01/cropped-fav-6-180x180.png" />
<meta name="msapplication-TileImage" content="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/01/cropped-fav-6-270x270.png" />

<!-- Button style compiled by theme -->

<style>
    
</style>

	<style id="tdw-css-placeholder">a.pe-optin-1_brandingWrapper {
  display: none;
}
.td-covid-country-name {
  display: none;
  visibility: hidden;
}
#trinityPlayer,
.wfContainerClass {
  background: rgba(255, 204, 0, 0.5);
}
.youtube-subscribe-bar iframe {
  height: 25px !important;
}
</style></head>

<body class="post-template-default single single-post postid-161347 single-format-standard" itemscope="itemscope" itemtype="https://schema.org/WebPage">

    
        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/ghpagenews/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/ghpagenews/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://t.me/ghpagemedia" title="Telegram">
                <i class="td-icon-font td-icon-telegram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/ghpage_com" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCov4vYMln30lLf2tukR6_YQ?sub_confirmation=1" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-secondary-menu-container"><ul id="menu-secondary-menu" class="td-mobile-main-menu"><li id="menu-item-14786" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14786"><a href="https://www.ghpage.com/category/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://www.ghpage.com/category/politics/">Ghana Politics</a></li>
	<li id="menu-item-27" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27"><a href="https://www.ghpage.com/category/business/">Business</a></li>
	<li id="menu-item-4823" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4823"><a href="https://www.ghpage.com/category/south-africa-news/">South Africa News</a></li>
	<li id="menu-item-4244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4244"><a href="https://www.ghpage.com/category/nigeria-news/">Nigeria News</a></li>
	<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33"><a href="https://www.ghpage.com/category/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-29" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-29"><a href="https://www.ghpage.com/category/entertainment/">Entertainment<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-4996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4996"><a href="https://www.ghpage.com/category/music/">Music</a></li>
</ul>
</li>
<li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31"><a href="https://www.ghpage.com/category/lifestyle/">Lifestyle<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-39" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://www.ghpage.com/category/health/relationship/">Relationship</a></li>
</ul>
</li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35"><a href="https://www.ghpage.com/category/sports/">Sports<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://www.ghpage.com/category/sports/ghana-sports/">Ghana Sports</a></li>
	<li id="menu-item-37" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37"><a href="https://www.ghpage.com/category/sports/international-sports/">International Sports</a></li>
</ul>
</li>
<li id="menu-item-30" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30"><a href="https://www.ghpage.com/category/health/">Health &#038; Wellness</a></li>
<li id="menu-item-110812" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110812"><a href="https://www.ghpage.com/category/events/">Events</a></li>
<li id="menu-item-7506" class="menu-item menu-item-type- menu-item-object- menu-item-7506"><a>Tech News</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.ghpage.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search" type="text" value="" name="s" autocomplete="off" />
				<input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
			</div>
		</form>
		<div id="td-aj-search"></div>
	</div>
</div>
    <div id="td-outer-wrap">
        <div class="td-header-wrap">
            <div class="td-container">
                <div id="td-header-menu">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo">
        
        <a class="td-mobile-logo" href="https://www.ghpage.com/">
            <img 
                 data-retina="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/08/ghpage-logo-w.png"
                 
                 alt="GHPAGE" title="GHPAGE" data-src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/08/ghpage-logo-w.png" class="td-retina-data lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="td-retina-data"
                 data-retina="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/08/ghpage-logo-w.png"
                 src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/08/ghpage-logo-w.png"
                 alt="GHPAGE" title="GHPAGE"/></noscript>
        </a>
        </div>
    <!-- Search -->
    <div class="td-search-icon">
                    <a id="td-header-not-live-search-button" href="https://www.ghpage.com/?s=" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
</div>            </div>
        </div>

        <div class="td-a-rec td-a-rec-id-header_mob "><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Mobile top ad Rec -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-4775187669258590"
     data-ad-slot="9077191472"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
	<div class="td-container">

	    <!-- breadcrumbs -->
	    <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.ghpage.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Entertainment" class="entry-crumb" href="https://www.ghpage.com/category/entertainment/">Entertainment</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Please forgive me- Lady who called Sally Galley horror and barren apologizes</span></div></div>

	    <!-- post content -->
	    
	    <article id="post-161347" class="post-161347 post type-post status-publish format-standard category-entertainment tag-selly-galley" itemscope itemtype="https://schema.org/Article">
		    <div class="td-post-header">

			    <ul class="td-category"><li class="entry-category"><a  href="https://www.ghpage.com/category/entertainment/">Entertainment</a></li></ul>
			    <header class="td-post-title">
				    <h1 class="entry-title">Please forgive me- Lady who called Sally Galley horror and barren apologizes</h1>
				    
				    <div class="td-module-meta-info">
					    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.ghpage.com/author/tabernacle/">Mr. Tabernacle</a><div class="td-author-line"> - </div> </div>					    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-14T19:29:11+00:00" >7:29 October 14, 2020</time></span>					    					    				    </div>
			    </header>

		    </div>

		    <div class="td-post-content">

			    <div class="td-post-featured-image"><figure><a href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley.jpg" data-caption="Henewaa Piesie and Selly Galley"><img width="696" height="392"   data-srcset="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley-696x392.jpg 696w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley-1068x601.jpg 1068w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley.jpg 1280w"  alt="Henewaa Piesie and Selly Galley" title="Henewaa-Piesie-and-Selly-Galley" data-src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley-696x392.jpg" data-sizes="(max-width: 696px) 100vw, 696px" class="entry-thumb td-modal-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="696" height="392" class="entry-thumb td-modal-image" src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley-696x392.jpg" srcset="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley-696x392.jpg 696w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley-1068x601.jpg 1068w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley.jpg 1280w" sizes="(max-width: 696px) 100vw, 696px" alt="Henewaa Piesie and Selly Galley" title="Henewaa-Piesie-and-Selly-Galley"/></noscript></a><figcaption class="wp-caption-text">Henewaa Piesie and Selly Galley</figcaption></figure></div>			    <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.ghpage.com%2Fplease-forgive-me-lady-sally-galley-horror-barren-apologizes%2F161347%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Please+forgive+me-+Lady+who+called+Sally+Galley+horror+and+barren+apologizes&url=https%3A%2F%2Fwww.ghpage.com%2Fplease-forgive-me-lady-sally-galley-horror-barren-apologizes%2F161347%2F&via=GhPage">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Please+forgive+me-+Lady+who+called+Sally+Galley+horror+and+barren+apologizes %0A%0A https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/&amp;media=https://www.ghpage.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley.jpg&description=Henewaa Piesie, the lady who called actress Selly Galley horror and barren has taken back her words and finally apologized. The">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-telegram" href="https://telegram.me/share/url?url=https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/&text=Please+forgive+me-+Lady+who+called+Sally+Galley+horror+and+barren+apologizes">
                                        <div class="td-social-but-icon"><i class="td-icon-telegram"></i></div>
                                        <div class="td-social-but-text">Telegram</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>			    
<p>The lady who got Selly Galley infuriated by her comments on social media causing her to rain generational curses on her has taken back her words and finally apologized.</p>



<div class="td-a-rec td-a-rec-id-content_inline_mob "><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-4775187669258590"
     data-ad-slot="2362252462"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><p>The lady&#8217;s apology comes after she took to Instagram to rather unanticipatedly make an awkward comment under the post of Selly Galley. Her post reads; ”horror face and barren woman”.</p>



<p><strong>See below the lady&#8217;s comment;</strong></p>



<figure class="wp-block-image size-large is-resized"><img loading="lazy"  alt="Selley Galley curses a lady 2"  width="641" height="809" data-src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Selley-Galley-curses-a-lady.jpg" class="wp-image-161288 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img loading="lazy" src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Selley-Galley-curses-a-lady.jpg" alt="Selley Galley curses a lady 2" class="wp-image-161288" width="641" height="809"/></noscript><figcaption>Selley Galley curses a lady 2</figcaption></figure>



<p>Vexed by the comments of the lady identified as Henewaa Piesie, actress Selly Galley in reply to the remark grief-stricken rained intergenerational curses on her. In fact, the cures are of high magnitude if you ask me.</p>



<p><strong>See below the one page curses Selly Galley dropped on Henewaa;</strong></p>



<figure class="wp-block-image size-large is-resized"><img loading="lazy"  alt="Selley Galley curses a lady 2"  width="692" height="873" data-src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Selley-Galley-curses-a-lady-2.jpg" class="wp-image-161287 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img loading="lazy" src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Selley-Galley-curses-a-lady-2.jpg" alt="Selley Galley curses a lady 2" class="wp-image-161287" width="692" height="873"/></noscript></figure>



<p>In a new post by the cursed lady, she has rendered an apology to Praye Tietia&#8217;s wife[Selly Galley] begging her for Mercy. </p>



<p>According to her words,  &#8216;It wasn&#8217;t her intention to hurt her[Selly] and family&#8217;. Henewaa Piesie included a prophetic word in her apology post that the actress will next year give birth.</p>



<p><strong>Read her apology below;</strong></p>



<figure class="wp-block-image size-large"><img loading="lazy" width="640" height="1333"  alt="Henewaa Apologizes to Selly Galley"  data-src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Apologizes-to-Selly-Galley.jpg" class="wp-image-161369 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img loading="lazy" width="640" height="1333" src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Apologizes-to-Selly-Galley.jpg" alt="Henewaa Apologizes to Selly Galley" class="wp-image-161369"/></noscript><figcaption>Henewaa Apologizes to Selly Galley</figcaption></figure>



<p></p>



<p> </p>
<div class="td-a-rec td-a-rec-id-content_bottom_mob "><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Mobile bottom article ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4775187669258590"
     data-ad-slot="5403490460"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>		    </div>

		    <footer>
			    			    
			    <div class="td-post-source-tags">
				    				    <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.ghpage.com/tag/selly-galley/">Selly Galley</a></li></ul>			    </div>

			    <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0"  style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;" data-src="https://www.facebook.com/plugins/like.php?href=https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.ghpage.com%2Fplease-forgive-me-lady-sally-galley-horror-barren-apologizes%2F161347%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Please+forgive+me-+Lady+who+called+Sally+Galley+horror+and+barren+apologizes&url=https%3A%2F%2Fwww.ghpage.com%2Fplease-forgive-me-lady-sally-galley-horror-barren-apologizes%2F161347%2F&via=GhPage">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Please+forgive+me-+Lady+who+called+Sally+Galley+horror+and+barren+apologizes %0A%0A https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/&amp;media=https://www.ghpage.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley.jpg&description=Henewaa Piesie, the lady who called actress Selly Galley horror and barren has taken back her words and finally apologized. The">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-telegram" href="https://telegram.me/share/url?url=https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/&text=Please+forgive+me-+Lady+who+called+Sally+Galley+horror+and+barren+apologizes">
                                        <div class="td-social-but-icon"><i class="td-icon-telegram"></i></div>
                                        <div class="td-social-but-text">Telegram</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>				<div class="a-sub">
				<h3> Get <b>Ghana Latest News</b> in your inbox each morning.</h3>
                <a class="sb"  href="https://forms.aweber.com/form/86/837822186.htm" target="_blank" rel="nofollow"><i class="td-icon-font td-icon-mail"></i> SUBSCRIBE</a>
			</div>
			<div class="td-all-devices">
				<a href="https://www.ghpage.com/recommends/cramp-pack/" rel="nofollow">
				<img  alt="Cramp Pack the immediate relief solution from menstrual discomfort." title="Cramp Pack the immediate relief solution from menstrual discomfort." data-src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/07/pandrhygiene.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/07/pandrhygiene.jpg" alt="Cramp Pack the immediate relief solution from menstrual discomfort." title="Cramp Pack the immediate relief solution from menstrual discomfort." /></noscript></a>
			</div>
				<!-- START TABOOLA ADDED BY AMIT 04.06.2018 19.06-->
				<div id="taboola-below-article-thumbnails"></div>
					<script type="text/javascript">
					  window._taboola = window._taboola || [];
					  _taboola.push({
						mode: 'thumbnails-a',
						container: 'taboola-below-article-thumbnails',
						placement: 'Below Article Thumbnails',
						target_type: 'mix'
					  });
					</script> 
					<!-- TABOOLA AMP -->
					<!-- pbad -->
					<amp-ad width="100vw" height="320"
						 type="adsense"
						 data-ad-client="ca-pub-4775187669258590"
						 data-ad-slot="8210309666"
						 data-auto-format="mcrspv"
						 data-matched-content-rows-num="5,4"
						 data-matched-content-columns-num="1,2"
						 data-full-width="">
					  <div overflow=""></div>
					</amp-ad>

					<!-- ENDS TABOOLA ADDED BY AMIT 04.06.2018 19.06-->
			    			    <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.ghpage.com/author/tabernacle/">Mr. Tabernacle</a></span></div>			    <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Mr. Tabernacle"></span><meta itemprop="datePublished" content="2020-10-14T19:29:11+00:00"><meta itemprop="dateModified" content="2020-10-14T19:29:13+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.ghpage.com/please-forgive-me-lady-sally-galley-horror-barren-apologizes/161347/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2019/08/ghpage-logo-w.png"></span><meta itemprop="name" content="GhPage"></span><meta itemprop="headline " content="Please forgive me- Lady who called Sally Galley horror and barren apologizes"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-and-Selly-Galley.jpg"><meta itemprop="width" content="1280"><meta itemprop="height" content="720"></span>		    </footer>

	    </article> <!-- /.post -->

	    <div class="td_block_wrap td_block_related_posts_mob tdi_1_655 td_with_ajax_pagination td-pb-border-top td_block_template_8"><h4 class="td-related-title">RELATED ARTICLES</h4><div id=tdi_1_655 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_mob_1 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="https://www.ghpage.com/refuse-apologise-telling-truth-nana-tornado-badu-kobi-lawsuit/161344/" rel="bookmark" class="td-image-wrap " title="I refuse to apologise for telling the truth- Nana Tornado on Badu Kobi lawsuit" ><img width="265" height="198"    data-srcset="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Nana-Tornado-Badu-Kobi-265x198.jpg 265w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Nana-Tornado-Badu-Kobi-485x360.jpg 485w"   alt="Nana Tornado Badu Kobi" title="I refuse to apologise for telling the truth- Nana Tornado on Badu Kobi lawsuit" data-src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Nana-Tornado-Badu-Kobi-265x198.jpg" data-sizes="(max-width: 265px) 100vw, 265px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="265" height="198" class="entry-thumb" src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Nana-Tornado-Badu-Kobi-265x198.jpg"  srcset="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Nana-Tornado-Badu-Kobi-265x198.jpg 265w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Nana-Tornado-Badu-Kobi-485x360.jpg 485w" sizes="(max-width: 265px) 100vw, 265px"  alt="Nana Tornado Badu Kobi" title="I refuse to apologise for telling the truth- Nana Tornado on Badu Kobi lawsuit" /></noscript></a></div>            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.ghpage.com/refuse-apologise-telling-truth-nana-tornado-badu-kobi-lawsuit/161344/" rel="bookmark" title="I refuse to apologise for telling the truth- Nana Tornado on Badu Kobi lawsuit">I refuse to apologise for telling the truth- Nana Tornado on...</a></h3>
                <div class="td-module-meta-info">
	                	                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-14T20:59:22+00:00" >  8:59 October 14, 2020</time></span>                </div>
            </div>

        </div>

        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_mob_1 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="https://www.ghpage.com/photos-henewaa-piesie-lady-selly-galley-cursed/161379/" rel="bookmark" class="td-image-wrap " title="Photos of Henewaa Piesie, the lady who Selly Galley cursed" ><img width="265" height="198"    data-srcset="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-1-265x198.jpg 265w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-1-485x360.jpg 485w"   alt="Henewaa Piesie" title="Photos of Henewaa Piesie, the lady who Selly Galley cursed" data-src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-1-265x198.jpg" data-sizes="(max-width: 265px) 100vw, 265px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="265" height="198" class="entry-thumb" src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-1-265x198.jpg"  srcset="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-1-265x198.jpg 265w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Henewaa-Piesie-1-485x360.jpg 485w" sizes="(max-width: 265px) 100vw, 265px"  alt="Henewaa Piesie" title="Photos of Henewaa Piesie, the lady who Selly Galley cursed" /></noscript></a></div>            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.ghpage.com/photos-henewaa-piesie-lady-selly-galley-cursed/161379/" rel="bookmark" title="Photos of Henewaa Piesie, the lady who Selly Galley cursed">Photos of Henewaa Piesie, the lady who Selly Galley cursed</a></h3>
                <div class="td-module-meta-info">
	                	                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-14T20:40:40+00:00" >  8:40 October 14, 2020</time></span>                </div>
            </div>

        </div>

        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_mob_1 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="https://www.ghpage.com/blakk-rasta-rains-insult-on-victoria-hamah-for-asking-for-his-ban-from-radio/161333/" rel="bookmark" class="td-image-wrap " title="Blakk Rasta rains insult on Victoria Hamah for asking for his ban from radio" ><img width="265" height="198"    data-srcset="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Blakk-Rasta-and-Vicky-Hamah-265x198.jpg 265w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Blakk-Rasta-and-Vicky-Hamah-485x360.jpg 485w"   alt="Blakk Rasta rains insult on Victoria Hamah for going for his ban from radio" title="Blakk Rasta rains insult on Victoria Hamah for asking for his ban from radio" data-src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Blakk-Rasta-and-Vicky-Hamah-265x198.jpg" data-sizes="(max-width: 265px) 100vw, 265px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="265" height="198" class="entry-thumb" src="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Blakk-Rasta-and-Vicky-Hamah-265x198.jpg"  srcset="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Blakk-Rasta-and-Vicky-Hamah-265x198.jpg 265w, https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/uploads/2020/10/Blakk-Rasta-and-Vicky-Hamah-485x360.jpg 485w" sizes="(max-width: 265px) 100vw, 265px"  alt="Blakk Rasta rains insult on Victoria Hamah for going for his ban from radio" title="Blakk Rasta rains insult on Victoria Hamah for asking for his ban from radio" /></noscript></a></div>            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.ghpage.com/blakk-rasta-rains-insult-on-victoria-hamah-for-asking-for-his-ban-from-radio/161333/" rel="bookmark" title="Blakk Rasta rains insult on Victoria Hamah for asking for his ban from radio">Blakk Rasta rains insult on Victoria Hamah for asking for his...</a></h3>
                <div class="td-module-meta-info">
	                	                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-14T17:09:46+00:00" >  5:09 October 14, 2020</time></span>                </div>
            </div>

        </div>

        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div></div> <!-- ./block -->
	</div>

	    <!-- footer AD -->
    
    <!-- footer -->
        <!-- sub footer -->
            <div class="td-mobile-sub-footer-wrap">
            <div class="td-container">

                    <div class="td-sub-footer-menu">
                        <div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="td-subfooter-menu"><li id="menu-item-2435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2435"><a href="https://www.ghpage.com/about-us/">About us</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23"><a href="https://www.ghpage.com/contact-us/">Contact us</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24"><a href="https://www.ghpage.com/advertise-with-us/">Advertise with us</a></li>
<li id="menu-item-2436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2436"><a href="https://www.ghpage.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-9368" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9368"><a href="https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/sitemap_index.xml">Sitemap</a></li>
</ul></div>                    </div>

                    <div class="td-sub-footer-copy">
                        &copy; 2016-2020 - GH-PAGE-MEDIA | All Rights Reserved.
#1 place for <a href="https://www.ghpage.com/">Ghana News</a>                    </div>

            </div>
        </div>
    
</div><!-- close td-outer-wrap -->


    <!--
        Theme: Newspaper Mobile Theme by tagDiv 2020
        Version: 10.3.6.1 (rara)
        Deploy mode: deploy
        
        uid: 5f878b655097a
    -->
    
<!-- Custom css from theme panel > mobile theme -->
<style type="text/css" media="screen">
/* custom css theme panel */
.a-sub{ padding: 20px 15px; border-top: 1px solid #e2e2e2;border-bottom: 1px solid #e2e2e2;background: #f5f5f5;text-align:center;}
.a-sub h3{font-weight: normal;}
.sb {background-color:#31a1ff; padding:10px; color:#ffffff; width:50%; display: inline-block;}
.sb:hover {background-color:#2c90e5;}
figcaption{
    text-align: left;
    margin: 0 0 26px 0;
    font-size: 12px;
    font-style: italic;
    font-weight: normal;
    line-height: 17px;
    color: #444;
}
</style>

<script type="text/javascript">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</script><script type='text/javascript' id='ta_main_js-js-extra'>
/* <![CDATA[ */
var thirsty_global_vars = {"home_url":"\/\/www.ghpage.com","ajax_url":"https:\/\/www.ghpage.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"recommends","link_prefixes":{"1":"recommends"},"post_id":"161347","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/thirstyaffiliates/js/app/ta.js?ver=3.10.0' id='ta_main_js-js'></script>
<script type='text/javascript' src='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.7.1' id='smush-lazy-load-js'></script>
<script type='text/javascript' src='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-content/plugins/td-composer/mobile/js/tagdiv_theme.min.js?ver=10.3.6.1' id='td-site-js'></script>
<script type='text/javascript' src='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-includes/js/comment-reply.min.js?ver=edf919ddf144a00b28d2c557749d4880' id='comment-reply-js'></script>
<script type='text/javascript' src='https://414046-1302474-2-raikfcquaxqncofqfm.stackpathdns.com/wp-includes/js/wp-embed.min.js?ver=edf919ddf144a00b28d2c557749d4880' id='wp-embed-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=edf919ddf144a00b28d2c557749d4880' async='async' id='remote_sdk-js'></script>

<!-- JS generated by theme -->

<script>
    
</script>

<script type='text/javascript' src='https://stats.wp.com/e-202042.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'112152826',post:'161347',tz:'0',srv:'www.ghpage.com'} ]);
	_stq.push([ 'clickTrackerInit', '112152826', '161347' ]);
</script>

</body>
</html>
